mediawiki-1.19.0 Installation


Seite: 1 2
Autor Beitrag
DarkSides
08.06.12 - 21:09:04 Uhr

Hi,

ich hab nach der wiki.pytal.de bearbeitet:
  1. Öffne die Datei \includes\AutoLoader.php und ersetze die Zeile 5  
  2. mit  
  3.  
  4.     //ini_set('unserialize_callback_func', '__autoload' );   


Ist aber nun nicht mehr Zeile 5 sondern ganz am Ende der Datei.

Und habe die Installations Datei im Browser aufgerufen und bekomme diese Meldung.

  1. Warning: require_once() [function.require-once]: Unable to access /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/normal/UtfNormalDefines.php in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/Defines.php on line 187  
  2.  
  3. Warning: require_once(/srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/normal/UtfNormalDefines.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/Defines.php on line 187  
  4.  
  5. Fatal error: require_once() [function.require]: Failed opening required '/srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/normal/UtfNormalDefines.php' (include_path='.:/srv/www/httpd/phost/d/de/pytalhost/darksides/web') in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/Defines.php on line 187  


Hat wer nen Tip, was zur Lösung führt?
Ditti4
08.06.12 - 21:12:29 Uhr

Ein paar Dateien wurden anscheinend nicht vollständig hochgeladen. Prüfe bitte nochmal, was fehlt.
DarkSides
08.06.12 - 21:38:56 Uhr

Ok danke.
War auch meine Vermutung, aber ich wollte sichergehen.
Dann schiebe ich alles noch mal hoch .... *cry*
DarkSides
08.06.12 - 22:03:29 Uhr

Nun eine neue Fehlermeldung.

Parse error: syntax error, unexpected T_STRING in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/LocalisationCache.php on line 629

*Grummel*
Gunni
08.06.12 - 23:16:16 Uhr

Hast du die Datei nocheinmal hochgeladen? Wenn das auch nichts hilft, zeig mal den Bereich um Zeile 629 her.
DarkSides
08.06.12 - 23:32:08 Uhr

  1. 629# like site-specific message overrides.  
  2.         $allData = $initialData;  
  3.         foreach ( $wgExtensionMessagesFiles as $fileName ) {  
  4.             $data = $this->readPHPFile( $fileName, 'extension' );  
  5.             $used = false;  
  6.  
  7.             foreach ( $data as $key => $item ) {  
  8.                 if( $this->mergeExtensionItem( $codeSequence, $key, $allData[$key], $item ) ) {  
  9.                     $used = true;  
  10.                 }  
  11.             }  
  12.  
  13.             if ( $used ) {  
  14.                 $deps[] = new FileDependency( $fileName );  
  15.             }  
  16.         }  
  17.  
Gunni
09.06.12 - 10:21:29 Uhr

Hm, sieht (bis aud die erste Zeile) eigentlich alles okay aus.
DarkSides
09.06.12 - 14:22:42 Uhr

Warning: ini_set() has been disabled for security reasons in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/LocalisationCache.php on line 454

Warning: ini_set() has been disabled for security reasons in /srv/www/httpd/phost/d/de/pytalhost/darksides/web/cms/includes/LocalisationCache.php on line 456

  1.     protected function readPHPFile( $_fileName, $_fileType ) {  
  2.         // Disable APC caching  
  3.         $_apcEnabled = ini_set( 'apc.cache_by_default', '0' );  
  4.         include( $_fileName );  
  5.         ini_set( 'apc.cache_by_default', $_apcEnabled );  


Zeile 454 $_apcEnabled = ini_set( 'apc.cache_by_default', '0' );


Zeile 456 ini_set( 'apc.cache_by_default', $_apcEnabled );

Das ist ja wie ein Staffellauf,
ein Problem gelöst geht es zum nächsten Problem weiter....!
DarkSides
09.06.12 - 21:50:54 Uhr

Ich meine wo gelesen zu haben, das man diese " ini_set " Variabeln mit // unwirksam machen muß.

Kann es sein das hier das auch der fall ist?
Ditti4
09.06.12 - 21:57:29 Uhr

Ist bei Pytal mit ini_set immer der Fall.
Seite: 1 2

- Obige Beiträge stellen keine Äußerung oder Meinung von Pytal oder dessen Betreiber dar -